Forum:(Sporkhack) Inexplicable YASD

From NetHackWiki
Jump to navigation Jump to search

Just now, something happened to me that has NEVER happened to me before - I died and I have no idea WHY or HOW.

Now, we all know that Nethack and its' variants have the habit of instakilling the player for the smallest of things, like turning a corner and getting blasted by black dragon or stepping into a dart trap and getting hit with lethal poison. But in this case, I do not understand how the game mechanics could possibly allow a YASD to happen.

Anyway, here's what happened:

I played an elven Ranger and had just entered the area of the Ranger Quest, starting off by aggroing a peaceful centaur (thought they were hostile), easily mowing through them. I should probably mention that I'm completely unspoilerd with regards to the Ranger and have never attempted this quest before. I then tried to enter the forest grove, but the only entrance I could was too small to pass through with the equipment I carried, so I tried to burn the tree in my way with the last charge of my Fire wand, only to find out that these trees reflect beams. No real damage done, so I continued to slaughter the Centaurs in the area. One of them used a scroll of create monster and generated a whole ton of other centaurs. Still, no problem. My armor class was low enough and I did fairly well at dispatching enemies with daggers. I kept close attention at the combat messages to make sure the game didn't throw any curve-balls. At this point, the enemies failed to even scratch me, even the occasional blast from a wand of striking didn't do anything (dwarven mithril coat), but then it happened:

I got this weird message I've never seen before, I quote:

"Elf, all your powers will be lost."

No idea what triggered it either, so I got worried and began to retreat, so I could zap my wand of enlightment to see if I could figure out whether this affected me in any way. Then right at the next turn I got killed. By a wand of striking. Instantly. At full HP. Even stranger, my HP weren't reduced to zero, rather the HP display was GONE.

I have no idea how this is even possible and can only assume that this is something Sporkhack-specific, since the the wiki doesn't have anything on this and the entrance area looked very different from what is depicted there.

I'm almost certain that it wasn't a wand of death that killed me, it said wand of striking. There also was no visible beam either, so that wouldn't be consistent with a WoD.

Unfortunately, I have no idea how to read the dumplog or retrieve the message history, which might shed some light on this.

This is a Hitpoint-related "wailing" message which indicates that you have less than 1/10 of your HP remaining. It seems that Sporkhack internally thought that you had low HP despite what the HP display said. It's probably some obscure bug that would be hard to track down; I've seen a few in-game Sporkhack corruptions due to longworms (seems fixed on latest patch) and, looking at the website, many others have been tracked down and fixed before development stopped. Sucks that it cost you a good player...--Gnominator 09:19, 8 January 2012 (UTC)
I have no real idea what might've happened, but based on your description it might be a display bug: it sounds as if, for some reason, Spork stopped updating your HP display even though you were actually taking damage. --Ilmari Karonen 17:21, 29 January 2012 (UTC)