From NetHackWiki
Jump to: navigation, search

A few months ago, while browsing this Wiki and reading about NetHack variants, I stumbled upon NetHack brass official homepage. Yes, it's in Japanese, but I happen to know the language a little, so I didn't leave immediately and looked through it. The bottom of the page contained a link simply named 'XanaHack', that led to this page. XanaHack archive (containing x86 Windows binary) can be downloaded by clicking on the fourth screenshot. I played it several times and really loved it. It seems to be an alternative GUI version as opposed to a gameplay veriant per se, but I may be wrong - a thorough investigation is needed. I didn't find any info about it here, on this wiki, so it is probably an overlooked gem. I get the feeling that it is based on NetHack 3.4.3, and the version of XanaHack itself is 0.03. I think that the development is halted, and we are dealing with alpha (or beta) version here. It has some nice and even cute features like background music, sound effects and tiles, with player and monsters even being animated. Player weapons, armour and status changes are also roughly reflected by tiles. Again, I didn't notice any gameplay changes (though I'm quite inexperienced when it comes to NetHack, so it may be my fault), but I think there are some bugs present too, unfortunately: the inventory can get glitchy if you pick a lot of items - the game for some reason can assign two items to the same letter of the same case, and after that one of the items becomes completely un-droppable. The 'adjust' command doesn't help, and when you try to drop the bugged item, the game just says that it does not exist in your inventory. It spoils the impression, of course, but I think it can't be helped, since it's just probably unfinished. The changelog (can be found in the game's folder in the file called 'change.txt') seems to indicate some fixed bugs related to the new interface and some minor changes... (you can press Ctrl+F in-game to get a centered mini-map of the current dungeon level). The project is probably abandoned, and even the Japanese people themselves (meaning those who know about NetHack) don't seem to be aware of XanaHack existence. If you have access to NicoNico Douga (kinda like the Japanese YouTube), please take a look at this video as well: This is a footage of XanaHack's gameplay (wasn't made by me). I would be glad to know more about this mysterious variant of NetHack (even if it will be just your personal opinion/impressions) from anyone who is interested! I think that we might add the information about XanaHack on this Wiki too, either as a separate page, or within the 'NetHack variants' chart. Axia (talk) 22:44, 6 September 2016 (UTC)

After reading this post I decided to try out this variant... Played a little bit around but didn't go much far. It looks like a fine graphical-port, done to look like a retro RPG-- there are sounds, animated-sprites and visual-effects. I can't read Japanese so the homepage made no sense to me and there isn't much information on the XanaHack page too so it won't help even if I could. It looks like it has gone defunct and thats probably why no one knows about it. The page itself offers little information, there's only a win32 binary without any source-code (it might be in violation of the NGPL but thats another story).
Gameplay-wise the game is good, the interface (a reminiscent of the old GameBoy RPGs of the 90s) shows all of the important information, including HP and Power, properly (a feature lacking in many graphical-ports like Falcon's Eye). There are animated graphics instead of static-tiles, there are several sound-effects and background-music and perhaps many other features that I've overlooked. From what I've played it feels much like the original 3.4.3-release but I can's say for sure. I also don't know if the game is complete or not and it'll take a while to figure it out. Fortunately Wizard-Mode is compiled into the game so I guess I can do a mock-ascension.
If the source was available I guess someone could bring this back to life as it looks like a really cool game but for now I don't think we should put this up in the wiki's variant page as it doesn't distribute the modified source-code thereby violating Paragraph-2 of the NGPL.
--Hexman (talk) 06:29, 3 December 2016 (UTC)
It's good to hear that somebody got interested in XanaHack, I already started to think that my post would get no answers! So, there are some license issues... This is very sad, really - because it effectively prevents making this variant known to NetHack public, and thus XanaHack's fate is probably going into oblivion eventually - that page can easily become "404" with time too... The license, if I understand it correctly, tells developers to provide some means to get the code in case the source wasn't included in the release. So, maybe there's a potential of getting the sources through contacting the developer (things will really be easier if the developer turns out to be the same as NetHack Brass one). And if this potential exists, there is no violation of NGPL at least on this term, is it? This is really a tough legal situation - should similar problems with defunct variants arise, the current license seems to demonstrate lack of flexibility. Oh, and have you encountered the messed-up inventory or any other bugs so far? Yes, doing Wizmode ascension is a great idea, I hope that some useful info about this game can be discovered this way.--Axia (talk) 21:59, 13 December 2016 (UTC)
Specifically it violates paragraph-3 which clearly asks the distributor to accompany it with the complete machine-readable source code, which must be distributed under the terms of Paragraphs 1 and 2. Contacting the original authors would be a great idea and I think that the owner of the main-page (the "NetHack brass" site) must know about them but I can't find anything on the main-page and even if there's some contact-information I won't be able to read it since it's all gibberish to me. I don't think the original authors wanted to violate the license since the win32-build contains a copy of the license and the Guidebook. But the lack of sources causes multiple problems: 1) The game cannot be redistributed as it's not legal and 2) Porting to other platforms besides 32bit-Windows is impossible.
About the game... well, I have not been able to play that much since my primary system is a Linux-machine but from what I've played I can safely say that I've not encountered any bugs. The messed-up inventory that you're talking about, I'm yet to experience -- even after I maxed out my inventory with lots of gems and stuff, it was displaying everything fine. I tried out the wizard-mode and played around a little-bit and everything was working as it should; even when you don't expect it to. For example, I thought the detect-foo feature would have been unimplemented as the game only shows a magnified dungeon and a tiny minimap but it worked, thanks to the "dungeon-overview" feature (Ctrl-F). You can even detect-traps with the cursed/confused gold-detection trick. The game is based on 3.4.3 release and it works as one would expect it to (for example, permanent-Elbereth is always permanent and wards off monsters even when you're not standing on it which is unlike 3.6.0).
If someone could get the source from the authors and make the game known to the general-public, I'm sure it would be a welcome addition to NetHack's variants.
--Hexman (talk) 12:23, 15 December 2016 (UTC)
I see. In order to track down the contacts, a serious detective/translation work is likely to be necessary. The inventory bug happened to me only once or twice - it seems to occur on a random basis (maybe only in rare situations), so I can't even say how to reproduce it. I definitely remember that it happened during my normal Valkyrie run, somewhere in the Mines. Specifically, the letter [v] was assigned to both the towel and some piece of armour in my inventory. Either that armour or the towel became undroppable (don't remember which one, but only one of the items was affected) with message "there's no such item" or something similar. I had a lot of items in my inventory then, that's also what I remember for sure, a lot of tools and gems among them. Anyway, it's good to hear that the game is probably quite stable. I was amazed at the presence of Detect feature too, since it was apparently broken even in Curses interface...Axia (talk) 15:04, 16 December 2016 (UTC)
I think I've managed to reproduce it! Well, sort of: now it's not about two items assigned to the same letter, but about one item only - I have a potion in my inventory, assigned to letter 'V' (there seems to be something wrong with this letter!). The game treats this potion as non-existent - I can't drop it, quaff it or anything else. I assume that the bug would be fully reproduced if I continue gathering items - some of the items might eventually be assigned to that "non-existent" letter, and I will end up with the same situation as I've described - two items assigned to one letter, one of them undroppable. Hexman, if you're still interested, I can even send you a savegame. Perhaps this happens only on specific computers and configurations? (I have an x64 computer and corresponding OS, and sometimes it generates problems with x86 applications).Axia (talk) 21:24, 19 December 2016 (UTC)
I tried this one as well. Judging by configuration file and in-game version command it seems to be based on 3.4.0 rather than on 3.4.3. Game has a large number of graphical artifacts. For example when you wear a shield without a weapon the sprite will be shown wielding a sword anyway. Dwarves met in Gnomish Mines look really well armored but this does not mean much. They can have no armor. It does create some sense of disconnect. I also really disliked my cat being represented as some kind of bird.
The look and feel of XanaHack reminded me of Necklace of the Eye roguelike game frontend. The idea has great potential, and if I wanted to attempt something what developer did my choice would be to use NotEye.
--Widmo (talk) 14:33, 21 December 2016 (UTC)