Forum:Disabling rogue level

From NetHackWiki
Jump to: navigation, search


Hi, is there a way to disable the rogue level(as in make it not appear,while a normal level at its place)? The tileset does not work on it and while I can handle bad graphics if the gameplay is good, I draw the line at ASCII...

Comment out this line at compile time.Kufat (talk) 23:38, 5 March 2015 (UTC)

Sorry if I am being obtuse but what is compile time? When I extract? And I don't see any file called config.

It's when you build Nethack (or any other program) from source code. If you're not doing that, you can't disable the Rogue level. Sorry. Kufat (talk) 01:34, 6 March 2015 (UTC)

And how do I do that?

See compiling. Kufat (talk) 01:49, 6 March 2015 (UTC)

There is something I am doing wrong. Unpacking the source only give me a nethack-343-scr.tar

Sorry, I can't really hang around to give you step by step instructions if you've never compiled a program or worked with standard *nix tools before. The wiki page I linked should help, and there're probably some helpful HOWTOs out there. Kufat (talk) 02:22, 6 March 2015 (UTC)
You're halfway there. Did you use gzip from a command line? You'll need to use "tar xvf nethack-343-src.tar" to finish the job. (Next time you get one of these, just run tar on it; it knows about gzip and several other compression programs.)
Or did you use 7-Zip? If so, you saw that file in 7-Zip's window. Just double click it and that'll show you what's in the distribution; you can then extract the files.
Either way, you should have a directory called "nethack-3.4.3" with a bunch of files under it. Head for sys/win32 and you'll find some READMEs there.
--Ray Chason (talk) 23:22, 6 March 2015 (UTC)

Thanks! I did it properly this time. However,when I run install.bat, it tell me there is no disk and that I must insert one?

There's no install.bat in the source tarball; perhaps you have a binary distribution? (And I misspoke; that should be sys/winnt.) Or you ran sys/winnt/nhsetup.bat, or some other script? There's no "insert a disk" message in that script.
What is the name of the file you unpacked? Can you name a few files that you found in it? What script exactly did you run, and what exact error message did you see?
I hope I'm not sounding pedantic. Computers sometimes frustrate me too, and I've been using them since 1980. Anything you tell me might possibly be of help. (Well, almost everything.)--Ray Chason (talk) 15:34, 7 March 2015 (UTC)

I followed the instructions on the compiling page from this wiki. I have the corrects subdirectories. I made the install.bat by copy-pasting this: PATH=%PATH%;c:\mingw\bin cd src mingw32-make -f makefile.gcc install But When I run it, it say: Il n'y a pas de disque dans le lecteur. Insérez un disque dans le lecteur I:.(It's in french,it mean: There is no disk in the disk drive. Insert a disk in the drive I:.)