Talk:Wizard mode

From NetHackWiki
Jump to: navigation, search

I don't under stand how to use it --Preceding unsigned comment added by 72.76.251.6 (talkcontribs)

I started a Wizard mode#Strategy section to explain some things. --Kernigh 02:52, 20 December 2006 (UTC)

The GDB hack doesn't work?

I tried the gdb hack, but when I did it on
/usr/local/bin/nethack
, is said “ no such executable”, and when I tried it on
/usr/local/share/nethack
, the games itself started, but gave me “No write permission to lock perm”, despite the fact the starting nethack normally starts fine.

76.121.93.40 01:38, 28 February 2015 (UTC)Elronnd


PocketPC version

NetHack 3.4.3 for Pocket PC doesn't allow the caret commands (e.g. ^W for a wish, ^G to create a monster etc). This is a bit of a problem, as it mostly defeats the purpose of entering Wizard mode. You do, however, start with a wand of wishing (0:3) to alleviate this somewhat.

Additionally, in this version you can't wish for a "chaotic altar", "altar" or the like, with an error message that reports that "there is no such object in the game" and returns another prompt for you to wish. -- Kalon9999 23:11, 12 November 2007 (UTC)

Why choose Umber Hulk corpses for a wish to sacrifice?

Does an Umber Hulk corpse last longer or is it much less heavier? --Puzzlet Chung 17:33, 6 January 2008 (UTC)

Probably because it gives a good alignment boost. I personally choose an appropriate unicorn. SheeEttin 22:05, 28 January 2008 (UTC)

Nethack-gnome wizard mode?

Can someone explain how to enter wizard mode using nethack-gnome? I get the following error when I run it from the command line:


Error on option -D: unknown option. Run '/usr/lib/games/nethack/nethack-gnome --help' to see a full list of available command line options.

That path is just a shell script that launches the binary with the nethackrc file. I tried running "gdb $path/nethack-gnome /etc/nethack/nethackrc.gnome" and couldn't get it to work as described in the text. It just spews a bunch of lines saying "(no debugging symbols found)". It also treats the binary and rc file as two separate gdb inputs so that breaks my attempt from the start.

One other question... can you enter wizard mode with if you have a saved game under a regular user since it seems to require running the game as root? Bucketoftruth 06:54, 7 July 2008 (UTC)

Level teleport to -1 and higher makes you die?

As far as I know by my experience one can teleport to from -1 to -5 without consequences, altough he'll always be sent at -1 first.

Lukky513 16:50, 2 September 2008 (UTC)

Macintosh Tiles

How do you run wizard mode in tiles for the Mac? Multiple google searches has been useless, as nothing offered has worked.

Multiple Bells of Opening

Has anyone ever tried this fun little nugget? Does it work on any system? I don't know but... If you ^G multiple quest nemeses, they drop Bells of Opening... then, when you pick up a second one, the messages are "already have silver bell?--More--" "Program in disorder - perhaps you'd better #quit." Does have any place in either the Bell of Opening or Wizard mode article? Aeronflux 16:09, 31 March 2009 (UTC)

Interesting... Sounds like the program checks this specifically, and if it finds it so, calls a trickery. -- Kalon 00:11, 1 April 2009 (UTC)
That's a Impossible error actually. --Rancalred (talk) 14:11, 24 June 2013 (UTC)

Fedora Core 11

This linux distro appears to require you to be logged in as user "games" in order to access wizard mode, not user "wizard". Any ideas on how to enable said account? I've tried doing so, but I still can't su to account games... 141.156.202.163 18:08, 12 August 2009 (UTC)

Spoiler(ishness)

Is using wizard mode a "spoiler" or an exploit? I have not used a single spoiler so far and hope to keep it this way, but using wizard mode would vastly help me get my legit characters past that underground city.

Whether you want to use wizard mode is up to yourself. Wizard mode is what we use to make sure the wiki (i.e. spoilers) are accurate. If you're running out of patience but still find out about everything yourself, you could try this: play a normal game, and whenever you get into a situation you don't know enough about, recreate it in a parallel wizard mode game for testing purposes. BTW, that's how I avoid save-scumming. -Tjr 16:59, December 13, 2009 (UTC)

Hidden Stairs

If one puts a pit over stairs, then fills the pit with a boulder, it hides the stairs. Is this a glitch, and is it fixable? Dracojounin7 19:13, January 17, 2010 (UTC)

At least it's a non-issue in normal games. -Tjr 20:21, January 17, 2010 (UTC)

Yes it appears that doing this will hide any object (stairs, fountain, sink, altar, etc). Fortunately the stairs will still be there, you just won't be able to see them and you won't get a message that they are there, but if you trying going > or < you will be able to. This only works for stairs, if you try to quaff from where there was a fountain you won't be able to. Again, we are lucky that you cannot use a wand of digging or a pick axe to dig into stairs in a normal game. Rockstar7514 23:21, February 19, 2010 (UTC)

There seems to be some problem with starting wizard mode in slash'em, i can't do it, but i have, and none of the suggested -D thingys seem to work. 213.107.94.26 19:51, January 22, 2010 (UTC) Apologies, it's happening in normal nethack too. Can't get it to run in wizard. 213.107.94.26 20:16, January 22, 2010 (UTC)

Getting into wizmode under windows

How the heck do I get into wizard mode on windows for the graphics version of nethack? Keep in mind I know very little about computers so make your explaination idiot proof. I don't understand how to start the game with the command neccesary to enter wizard mode.

I can't answer for Windows, but on Mac OS X the trick is to find out which line of commands in the "DOS box" is the equivalent of a click, and then to append -D to it. Tjr 16:16, July 8, 2010 (UTC)
what does DOS mean?
Wikipedia:Command_Prompt

#enhance

Using the #enhance extended command while in wizard mode allows you to enhance skills without having trained them the correct number of times. Thought it might be nice to have on the page but I didn't know where to add it. --Xannon (talk) 16:51, 14 November 2012 (UTC)

Perhaps a new section mentioning differences in command behaviour in normal gameplay and wizmode? ——paxed (talk) 17:06, 14 November 2012 (UTC)

Unix

I've changed the Unix section to something which more closely resembles the situation with 3.6.0, and to tidy it up a bit (as I see it). Some of the things I've done are:

  • Remove the reference to Debian/Ubuntu, as there are other Linux distributions which include a version of NetHack in which root has access to wizard mode.
  • Treat sudo+shell escape as being dangerous by itself, as it circumvents the "sudo commands are logged" thing.
  • Add a description of the sysconf file added in 3.6.0 (although I understand that this wasn't its first appearance).
  • Put macOS (the newest name for Mac OS X, apparently) in a separate section, because I have no idea if anything else in the UNIX one is relevant to it.

I don't know a lot about sudo or macOS, and haven't tried the gdb one as I'd need to recompile NetHack first to get a copy with debug symbols. Hoanwan (talk) 02:55, 4 November 2016 (UTC)